BerandaComputers and TechnologyMembuat TensorFlow dan PyTorch berfungsi pada RTX 3090, 3080, 3070

Membuat TensorFlow dan PyTorch berfungsi pada RTX 3090, 3080, 3070

Masalah
Mulai 6/11/2020, Anda tidak dapat melakukan pip / conda menginstal versi TensorFlow atau PyTorch yang berjalan pada NVIDIA RTX 30 GPU seri (Ampere). GPU ini memerlukan CUDA 11.1, dan rilis TensorFlow / PyTorch saat ini tidak dibuat berdasarkan CUDA 11.1. Saat ini, membuat pustaka ini bekerja dengan 30XX GPU membutuhkan kompilasi manual atau kontainer buruh pelabuhan NVIDIA.

Solusi
Lambda Stack, paket Ubuntu 20.04 APT yang tersedia secara gratis yang dibuat oleh Lambda (kami merancang workstation dan server pembelajaran mendalam dan menjalankan Cloud GPU publik ). Lambda Stack menginstal dan mengelola versi TensorFlow dan PyTorch daripada yang dapat dijalankan di RTX 3090, RTX 3080, dan RTX 3070.

Peringatan
cuDNN terbaru tidak dioptimalkan untuk RTX 30 seri. Versi yang lebih cepat akan dirilis dalam waktu dekat.

Lambda Stack termasuk

  • TensorFlow v2.3.0
  • PyTorch v1.6.0
  • CUDA v11.1
  • cuDNN v7.6.5
  • Dependensi dan kerangka kerja lain seperti Caffe dan Theano

Persyaratan sistem

  • GPU NVIDIA (mis. RTX 3090, 3080, 3070, 2080 Ti, Quadro RTX 8000)
  • Ubuntu 20.04 LTS (Fossa Fokus)

Instal Lambda Stack (versi desktop)

  LAMBDA_REPO=$ (mktemp) &&  wget -O $ {LAMBDA_REPO} https://lambdalabs.com/static/misc/lambda-stack-repo.deb &&  sudo dpkg -i $ {LAMBDA_REPO} && rm -f $ {LAMBDA_REPO} &&  sudo apt-get update && sudo apt-get install -y lambda-stack-cuda  

Nyalakan ulang mesin Anda.

Instal Lambda Stack (versi server)

  LAMBDA_REPO=$ (mktemp) &&  wget -O $ {LAMBDA_REPO} https://lambdalabs.com/static/misc/lambda-stack-repo.deb &&  sudo dpkg -i $ {LAMBDA_REPO} && rm -f $ {LAMBDA_REPO} &&  sudo apt-get update &&  sudo apt-get --ya tingkatkan &&  sudo apt-get install --yes --no-install-merekomendasikan lambda-server &&  sudo apt-get install --yes --no-install-merekomendasikan nvidia-headless-455 &&  sudo apt-get install --yes --no-install-merekomendasikan lambda-stack-cuda  

Nyalakan ulang mesin Anda.

Mulai menggunakan TensorFlow / PyTorch

  $ python>>> impor tensorflow>>> tensorflow .__ version__ '2.3.0'>>> impor obor>>> obor .__ versi__ '1.6.0'  

Kelola instalasi TensorFlow / PyTorch Anda

Jika versi baru PyTorch, TensorFlow, CUDA, cuDNN dirilis, jalankan saja:

  sudo pembaruan apt-get && sudo apt-get dist-upgrade  

Nyalakan ulang mesin Anda.

Tertarik dengan stasiun kerja GPU, server, atau instance cloud?

Read More

RELATED ARTICLES

LEAVE A REPLY

Please enter your comment!
Please enter your name here

Most Popular

Recent Comments